APPLIES TO


Email Signature Manager version 5.x

Email Signature Manager version 6.x


SUMMARY


This article describes how to resolve rare error messages that may occur in different parts of the application when using Email Signature Manager with the settings.mdb database on a network share, which is the most common type of installation.


SYMPTOMS


When using Email Signature Manager with the settings.mdb database on a network share, you receive one or more of the following error messages:


  • Unrecognized database format.
  • The search key was not found in any record.
  • Dynamic SQL generation for the UpdateCommand is not supported against a SelectCommand that does not return any key column information.
  • Operation must use an updateable query.
  • The provider could not determine the Object value. For example, the row was just created, the default for the Object column was not available, and the consumer had not yet set a new Object value.


CAUSE


These errors occur when the settings.mdb database has become corrupted.


RESOLUTION


To repair the corruption:


  1. Open Email Signature Manager.

  2. Open the Settings Database dialog.

  3. Click the Repair & Compact button.


If the problem persists, the configuration of the application can be changed to prevent it from reoccurring in one of two ways:


Migrate to SQL Server or SQL Server Express


This is the preferred option, as Microsoft SQL Server provides a scalable and reliable solution to this problem. Please refer to the User's Guide for a step-by-step guide on using SQL Server:


Version 5: http://docs.symprex.com/email-signature-manager/551/html/using_microsoft_sql_server.htm

Version 6: http://docs.symprex.com/email-signature-manager/640/html/using_microsoft_sql_server.htm


Enable Status Files


This option configures Email Signature Manager to record status information in files, instead of recording the information in the database.


Status files are enabled on the Advanced tab of the Deployment Options dialog.