APPLIES TO
Email Signature Manager version 5.x
Email Signature Manager version 6.x
SUMMARY
This article describes the symptoms and cause of an unexpected error that may occur when trying to configure the Email Signature Manager Transport Agent using the Email Signature Manager Transport Agent Configuration Utility. This article also describes the resolution for this issue.
SYMPTOMS
An unexpected error occurs when trying to save settings in the Email Signature Manager Transport Agent Configuration Utility:
Exception #1 (System.Security.SecurityException): Access to the registry key is denied
at Symprex.RuntimeSupport.RegistryKeyEx.#4B(#Jb , RegistryHive , String )
at Symprex.RuntimeSupport.RegistryKeyEx.#4B(RegistryHive , String )
at #ABe.#80.#Kpb(Object , EventArgs )
CAUSE
The user who is running the Email Signature Manager Transport Agent Configuration Utility does not have administrative rights and therefore settings cannot be saved to HKEY_LOCAL_MACHINE in the Windows Registry.
RESOLUTION
Run the Email Signature Manager Transport Agent Configuration Utility using Run As Administrator.
STATUS
The problem is resolved as described above.
The problem no longer occurs when using Email Signature Manager 7.0.0 and later.