APPLIES TO


Out-of-Office Manager version 5.x
Out-of-Office Manager version 6.x

Out-of-Office Manager version 7.x


SUMMARY


This article describes the symptoms and cause of an unexpected error occurring, seemingly randomly, when expanding address lists or groups. This article also describes the resolution for this issue.


SYMPTOMS


The application is connected to Exchange Server 2010 or later.


An unexpected error with the following details occurs, seemingly randomly, when expanding address lists or groups:


Operation: Get address entries for object 'Global Address List' (GlobalAddressList)
Method: Symprex.SXMAPI.DataProvider.PrivateGetAddressEntries()
Object: 'Global Address List', Type = GlobalAddressList


Message: [GetAddressListAddressEntries@1400][ReadMAPITable@1600]Error in IMAPITable.QueryRows: MAPI_E_CALL_FAILED
Error Code: 0x80004005 (-2147467259)
Error Description: <Message not available for error 0x80004005>


In this example the unexpected error occurred when expanding the "Global Address List" address list.


CAUSE


The unexpected error occurs because of one of the following reasons:


  • Client throttling policies have not been disabled for the user of the application.
  • Changes to client throttling policies do not become effective immediately.


RESOLUTION


In order for the application to function correctly with Exchange Server 2010 and later, it is necessary to disable client throttling for each user of the application.


Refer to the user's guide for your version of the application for more information (press F1 from the main window to open).


Please note that changes to client throttling policies may not become effective immediately.


STATUS


The problem is due to missing throttling policy configuration on Exchange Server 2010 or later.


The problem is resolved as described above.