APPLIES TO


Email Signature Manager version 5.x

Email Signature Manager version 6.x


SUMMARY


This article describes the symptoms and cause of an unexpected error that may occur when trying to start the Email Signature Manager Service from Email Signature Manager. This article also describes the resolution for this issue.


SYMPTOMS


An unexpected error occurs when trying to start the Email Signature Manager Service from Email Signature Manager:


Exception #1 (System.InvalidOperationException): Cannot open SYMPREXESMS service on computer '.'.

   at System.ServiceProcess.ServiceController.GetServiceHandle(Int32 desiredAccess)

   at System.ServiceProcess.ServiceController.Stop()

   at #Z.#CHb.#Neb()

   at #XZ.#p4d.#gce(Object , DoWorkEventArgs )

 

Exception #2 (System.ComponentModel.Win32Exception): Access is denied

 

CAUSE


The user who is running Email Signature Manager is a regular domain user and therefore does not have permission to start, stop or otherwise configure services.


RESOLUTION


Logon to Windows as a domain administrator when configuring the Email Signature Manager Service in Email Signature Manager.


STATUS


The problem is resolved as described above.


The problem no longer occurs when using Email Signature Manager 7.0.0 and later.